I am having difficulty installing the DataRobot python API in our development environment. There seems to be a mismatch between the package's requirements in its conda-forge vs. pypi packaging, which is causing the dependency solver to fail.
From the PyPi package's PKG-INFO / requires.txt, the only requirements are:
- attrs >=19.1.0,<20.0
- contextlib2 >=0.5.5
- pandas >=0.15
- python >=3.6,<3.10
- pyyaml >=3.11
- requests >=2.21
- requests-toolbelt >=0.6
- trafaret <2.0,>=0.7,!=1.1.0
- urllib3 >=1.23
Solved! Go to Solution.
This reply does not comply with our community guidelines, so it is being removed. Please review the community guidelines before making posts in the future.
@hoffmanr Thank you very much for the PR. We accepted it and have updated the conda-feedstock repo. This should close this issue permanently on our end.
Your earlier discovery is correct -- we had added the constraint after we found issues with the library in Python 3.10. We resolved those issues, but never removed the constraint. Apologies for the inconvenience.
FYI, I made a PR with a proposed fix on that recipe at the link below, in case you want to add it to your internal bug tracking. Thanks!
Thank you for your response this is a problem indeed. Will escalate this and come back when I will know more.
UPD: we create a bug for this, and hope will solve it soon.
version 3.0.2 - see the Conda-forge feedstock recipe here - https://github.com/conda-forge/datarobot-feedstock/blob/main/recipe/meta.yaml
And actually, in finding that recipe source link, I found a hint as to what happened - back at v2.27, a Leah Perri put that python version constraint on it. However, it was never reverted in later versions or for 3.0.
To my personal knowledge conda-forge version of datarobot lags behind pypi. Can you verify which datarobot versions they are trying to install? The lag in versions could explain the difference you see.
Currently, this platform is the main place for such questions, but we are looking into splitting for more technical questions.