Showing results for 
Search instead for 
Did you mean: 

How to configure a Sharepoint Data Source

Linear Actuator

How to configure a Sharepoint Data Source

To configure a connection to Sharepoint from Paxata, you will need to enter the following parameters:

Server URL  e.g. https://<yoursharepointaddress>/sites/<yoursite>;

0 Kudos
6 Replies

I get a Failed to login into "https://sharepointaddress/sites/mysite/": invalid username or password. Even though I am the owner of the site. I've tried both username and domain\username with same results
0 Kudos

When logging in to your Sharepoint site, are you typically required to provide the domain of your account?
0 Kudos

I don't have to login to SharePoint as it uses my windows credentials. I did try both username and domain\username with my password and get the same error message
0 Kudos

Interesting, it sounds like you're using Active Directory or some other sort of single-sign-on to log you into SharePoint without having to directly enter your credentials. Is this the case?

If so, are you able to log directly into SharePoint using your credentials outside of the SSO process? 

It may require speaking to your SharePoint admin to understand how they have configured authentication into your environment as you may only be able to log in via the SSO process.  

@sudheerkumar may also have some insight on this as he is your Paxata Customer Success contact would be most likely to have knowledge of your environment. 

0 Kudos

Regarding sharepoint - I am getting an error "Unable to fetch contents of folder". 
Is this somehow related to permissions ?

I am getting a successful message on clicking "test data source". Please advise

0 Kudos

@sid3011 - So sorry I missed your question a while back. I do believe your issue is permissions related. The "Test Data Source" feature only checks whether a connection can be established between Paxata and the Data source you've configured, it does not attempt to read or import a file. So your intuition is most likely correct, that this issue is permissions related. 

Have you been able to resolve this issue? If not, please reach out to your Customer Success contact and we can help resolve this. If so, would you mind posting your solution to the community? 
0 Kudos