Showing results for 
Search instead for 
Did you mean: 

Time-Series Feature Selection in R Error

Image Sensor

Time-Series Feature Selection in R Error

Does anyone have experience with using the notebook from Advanced Feature Selection with R | DataRobot Community?


Two issues I am having with it:


1. The ListModels function is throwing an error, the traceback is below.

2. I am expecting to run into problems modifying it to work with Time Series projects. So if anybody has advice with feature selection for TS models I would appreciate it.



Error in curl::curl_fetch_memory(url, handle = handle) : Protocol "" not supported or disabled in libcurl
curl::curl_fetch_memory(url, handle = handle)
request_fetch.write_memory(req$output, req$url, handle)
request_fetch(req$output, req$url, handle)
request_perform(req, hu$handle$handle)
(function (url = NULL, config = list(), ..., handle = NULL) { hu <- handle_url(handle, url, ...) req <- request_build("GET", hu$url, as.request(config), ...) ...
4., args)
MakeDataRobotRequest(httr::GET, routeString, addUrl = addUrl, returnRawResponse = returnRawResponse, ...)
DataRobotGET(routeString, simplify = FALSE, query = params)

Labels (2)
14 Replies

I managed to get the python script working (from the original article). Still cannot get the R function 'ListModels" to work.

0 Kudos

Hi @GR - are you still struggling with this?

0 Kudos

So I ran from the vignette:


data <- read.csv(system.file("extdata", "multiseries.csv", package = "datarobot"))
partition <- CreateDatetimePartitionSpecification(datetimePartitionColumn = "timestamp",
useTimeSeries = TRUE,
multiseriesIdColumns = "series_id")
project <- StartProject(data,
projectName = "test-TimeSeries",
target = "target",
partition = partition,
metric = "RMSE",
mode = AutopilotMode$Manual,
targetType = "Regression")


which threw


Project test-TimeSeries creation requested, awaiting creation
No encoding supplied: defaulting to UTF-8.
Error in if (grepl("//$", url) || grepl("\\s", url) || !grepl("/", url)) { :
missing value where TRUE/FALSE needed


The data file had some strange corruption.




But I adjusted the script to work with the data used in the TS project I am working on (via local import) and it gave the same error.


You're welcome! Thanks for your patience as we continue to work on this.


Can you confirm if the functionality at is working for you? This isn't about `ListModels()` exactly but I want to diagnose if there are multiple issues for you and your Time Series projects or if we should just isolate on `ListModels()`.

0 Kudos

My bad, I read your or as an and.


I have tried both types of projects, none worked, all with the same error/traceback. Thanks for taking a look at this I appreciate it!

0 Kudos

I think you are saying this is only for time series projects? Can you check if it works on a machine learning project for you?


Thanks for answering all these questions! Still just trying to diagnose where the issue might be.

0 Kudos


0 Kudos

And these are all time series projects or some non-time series too?

0 Kudos

Just tried a few project IDs with ListModels. Good suggestion but still no luck. 

0 Kudos

Thanks for confirming. Just as one more check, are you having this issue with ListModels on different projects as well?