cancel
Showing results for 
Search instead for 
Did you mean: 

datarobot with pandas 1.4

dylanscott
Blue LED

datarobot with pandas 1.4

Hi, I noticed that in the changelog for the latest (2.28.0) release of the datarobot package it says

  • pandas upper version constraint is updated to include the latest version.

However this does not appear to be true. At the time of that release the latest Pandas version was 1.4.1 and is now 1.4.2. Could the datarobot package be updated to include Pandas 1.4 in the constraint? I don't believe any backwards incompatible changes apply to datarobot's use of Pandas and this is blocking us from upgrading.

0 Kudos
4 Replies
ahjota
DataRobot Employee
DataRobot Employee

Thought I'd follow up here. The newest stable version of datarobot 2.28.1 has the pandas constraint relaxed.

https://pypi.org/project/datarobot/

ahjota
DataRobot Employee
DataRobot Employee

Hi Dylan! We're looking at relaxing the Pandas version constraint now. I'll update here if we're able to include this in the next release.

Thanks for the info @KyryloPerevozchykov . Is there any way datarobot would consider relaxing the Pandas version constraint in the next release? All of our other dependencies only provide a lower bound on their Pandas dependency (or just a * dependency). Having an upper bound, particularly one set to a specific minor version, makes it very difficult to manage. 

0 Kudos

Hello!

Unfortunately, that is a mistake in a release notes. By the time the change was added into 2.28.0 bulk of change `1.3.x` version of pandas was a latest. 
One of the workarounds would be to reinstall latest pandas after datarobot install. 

0 Kudos