cancel
Showing results for 
Search instead for 
Did you mean: 


Error while uploading prediction datasets

ranand
Blue LED

I am able to train and test my model on my data robot API but when i am trying to run my codes through python it is working fine till retraining my model but when i am uploading a data set for prediction it is throwing me a "single class actual value data quality" error. Attachecode for uploading dataset.pngdata robot error.pngd are my code for uploading prediction data set and error received

Labels (2)
7 Replies
a_shoop
DataRobot Employee
DataRobot Employee

Hi @ranand ,

Thanks for your question about an API error when uploading prediction datasets.

I have a couple clarification questions and then a suggestion for you:

  • Could you please show us your DataRobot API client version? You can do this from your jupyter notebook via the following command:
!pip list | grep datarobot
  • If you happen to know, it would be helpful to know what is the DataRobot version of your server/cluster. It could be DataRobot v5.3 or v6.0 or so forth.

Finally, it could be that your version of the DataRobot API client is mismatching with the ideal version meant to be used on a given DataRobot install/cluster version.

In other words, please try install the following version of `datarobot` and retry your predictions dataset upload.

!pip install datarobot==2.20.3

 

Please let us know how it goes, we're happy to help!

0 Kudos
ranand
Blue LED
My data robot version is 2.23. However i tried changing it to 2.20.3 as suggested but the error still persists
0 Kudos
Linda
Community Team
Community Team

Hi again @ranand - I see you're still having issues after installing the 2.20.3 version of the DR API client.

@a_shoop also asked what version of the DataRobot platform you're using -- maybe "v5.3 or v6.0 or so forth".

Can you send that along too? I know it will help when troubleshooting your issue.

 

0 Kudos
doyouevendata
DC Motor

Note when logged out of the DataRobot GUI, you will see its version on the sign in screen in your browser.

0 Kudos
ranand
Blue LED

The Datarobot version is v6.0.2

0 Kudos
doyouevendata
DC Motor

6.0.2 is associated with python sdk client 2.20.  It can be installed with:

pip install "datarobot>=2.20,<2.21"

 

or perhaps alternatively the base client could be tried:

pip install datarobot==2.20.0

ranand
Blue LED

Installing data robot using pip worked as suggested in last answer.

Thank you  for the help!